博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
POJ-2159(Water)
阅读量:6070 次
发布时间:2019-06-20

本文共 3265 字,大约阅读时间需要 10 分钟。

2159:Ancient Cipher

时间限制:

1000ms

内存限制:

65536kB

描述

Ancient Roman empire had a strong government system with various departments, including a secret service department. Important documents were sent between provinces and the capital in encrypted form to prevent eavesdropping(窃听、窃取). The most popular ciphers in those times were so called substitution cipher and permutation cipher.

Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all letters must be different. For some letters substitute letter may coincide with the original letter. For example, applying substitution cipher that changes all letters from 'A' to 'Y' to the next ones in the alphabet, and changes 'Z' to 'A', to the message (1)"VICTORIOUS" one gets the message (2)"WJDUPSJPVT".
Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation <2, 1, 5, 4, 3, 7, 6, 10, 9, 8> to the message "VICTORIOUS" one gets the message "IVOTCIRSUO".  
It was quickly noticed that being applied separately, both substitution cipher and permutation cipher were rather weak. But when being combined, they were strong enough for those times. Thus, the most important messages were first encrypted using substitution cipher, and then the result was encrypted using permutation cipher. Encrypting the message "VICTORIOUS" with the combination of the ciphers described above one gets the message (3)"JWPUDJSTVP".
Archeologists(考古学家) have recently found the message engraved on a stone plate. At the first glance it seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that was encrypted, and now they want to check their conjecture. They need a computer program to do it, so you have to write one.

输入

Input contains two lines. The first line contains the message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so the encrypted message contains only capital letters of the English alphabet. The second line contains the original message that is conjectured to be encrypted in the message on the first line. It also contains only capital letters of the English alphabet.

The lengths of both lines of the input are equal and do not exceed 100.

输出

Output "YES" if the message on the first line of the input file could be the result of encrypting the message on the second line, or "NO" in the other case.

样例输入              

JWPUDJSTVP      

VICTORIOUS      

样例输出

YES

 

Tips:

明文与密文的字母频率的数组应该是一样的,即明文中某字母出现8次,密文中也必须有某个字母出现8次。

所以字母种类,字母频率同时相等时,即被破解。

#include"iostream"

#include"string"
using namespace std;
int main()
{
 string initial,encrypted;
 cin>>initial;
 cin>>encrypted;
 int a[26],b[26];//标记initial和encrypted的26个字母的出现频率
 for(int i=0;i<26;i++)
     a[i]=0;
 for(int i=0;i<26;i++)
     b[i]=0;
 for(int i=0;i<initial.size();i++)
 {
  a[initial[i]-'A']++;
  b[encrypted[i]-'A']++;
 }
 int i,j;
 for(i=0;i<26;i++)
 {
  for(j=0;j<26;j++)
   if(a[i]==b[j])
   {
    b[j]=-1;//标记已经取出的encrypted的频率
    break;
   }
  if(j==26)//说明initial的某个字母的频率所有encrypted的字母频率均无法匹配
   break;
 }
 if(j==26)//匹配失败
  cout<<"NO"<<endl;
 else if(i==26)//匹配成功
  cout<<"YES"<<endl;
}

转载于:https://www.cnblogs.com/lzhitian/archive/2011/08/16/2140074.html

你可能感兴趣的文章
1.1 学习之初 1.2 约定 1.3 认识Linux 1.4 安装虚拟机 1.5 安装centos7
查看>>
一张图读懂“云栖大会·南京峰会”重磅发布产品
查看>>
hi3519/hi3516AV200交叉编译opencv的精简版本
查看>>
区块链100讲:如何使用开发环境命令行注册EOS靓号及变更EOS账号的active key和其他...
查看>>
区块链100讲:以太坊智能合约solidity如何节省GAS费?
查看>>
解决python3中解压zip文件是文件名乱码的问题
查看>>
lucene 评分要素解析
查看>>
为什么学习大数据,大数据专家写给大数据分析学习者的10个理由
查看>>
学习Python时最容易遇到的12种错误希望可以让你避开这些坑!
查看>>
VIM 使用
查看>>
模板设计模式
查看>>
如何优雅的编程——C语言界面的一点小建议
查看>>
Visual Paradigm 教程[企业架构]:如何使用TOGAF ADM软件(一)
查看>>
Java核心-反射和动态代理(JDK Proxy和Cglib)
查看>>
深度解析vue组件之间通信【8种方式】实例
查看>>
Python SMTP发送邮件
查看>>
【更新】Essential Studio for ASP.NET MVC更新至2018 v4(一)
查看>>
正确的打日志姿势
查看>>
【Nvivo教程】Nvivo中的协同合作
查看>>
使用prometheus监控nginx
查看>>